oclvanitygen, openssl i ubuntu 16 lub 18

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » sobota, 2 marca 2019, 07:48

Ubuntu (16.04 lub 18.04) serwer 64bit
karta AMD Radeon VX7950
potrzebuje skompilowac oclvanitygen
Nie ogarniam wersji bibliotek/driverow. W sieci jest 100 tutoriali na ten temat ale copy/paste tego co powinno byc doinstalowane przed kompilacja nie dziala. Caly czas dostaje bledy zwiazane z openssl. System nie widzi tez karty po uzyciu komendy clinfo powinien jak sadze wiec byc moze jakies drivery sa dodatkowo potrzebne.
Sadze ze problem jest podobny jak przy koparkach - tam tez zapewne trzeba zmusic ubuntu by zobaczyl karte.
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Początkujący
Posty: 46
Rejestracja: 5 czerwca 2012
Reputacja: 23
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: dymonek » sobota, 2 marca 2019, 13:48

to może na sam początek jakie masz info jak wpiszesz

openssl version

?
Jakie dokładnie masz błędy :) może taki
Obrazek
za chwile maszyne postawie wirtualną i sprawdze u siebie :P
mowa jest o tym repo
https://github.com/samr7/vanitygen
? bo też powstały jakieś vanitygen plus itp itd

Swojego czasu bawiłem się Vanitygen-em gdy kopanie przestało się opłacać xD i myślałem, że może uda mi się trafić na jakiś z tych adresów https://vanitypool.appspot.com/availableWork to pare groszy by wpadło.

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » sobota, 2 marca 2019, 14:19

@dymonek
Dzieki za zainteresowanie.
Probowalem i starego i plusa. Zadnego nie moge skompilowac.
Dodam jeszcze ze vanitygen sie kompiluje i dziala - problem jest tylko z GPU
ubuntu 18.04
OpenSSL 1.1.0g 2 Nov 2017
-----------------------------------
make all
cc -ggdb -O3 -Wall -c -o oclvanityminer.o oclvanityminer.c
oclvanityminer.c:26:10: fatal error: openssl/ec.h: No such file or directory
#include <openssl/ec.h>
^~~~~~~~~~~~~~
compilation terminated.
<builtin>: recipe for target 'oclvanityminer.o' failed
make: *** [oclvanityminer.o] Error 1

Dodano po 6 minutach 2 sekundach:
Dodam jeszcze ze teraz nie mam czystego systemu bo juz kilka innych bledow wyeliminiwalem za pomoca googlania :-)
Ale w tym miejscu stoie i nie moge sie ruszyc dalej
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Początkujący
Posty: 46
Rejestracja: 5 czerwca 2012
Reputacja: 23
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: dymonek » sobota, 2 marca 2019, 14:31

Pobawie się i dam znać, zainstalowałem czyściocha ubuntu 18.04 i też non stop dostaje errory :D
Obrazek
i szczerze mówiac te pare lat temu nie pamietam( zdaje sie ubuntu 14.04 ), żebym byly takie akcje xD wiem, że to mało pomocne :D ale no dam znać jak coś wyczaruje.

kurcze xD zainstalowałem ubuntu 14.04 i poszło od razu

Obrazek

dla ubuntu 14.04 wystarczy

apt update
apt install git
apt install build-essential libtool autotools-dev autoconf libssl-dev libdb-dev libdb++-dev libboost-all-dev libpcre3 libpcre3-dev automake

git clone https://github.com/samr7/vanitygen
cd vanitygen
make
i juz działa wszystko
Ostatnio zmieniony sobota, 2 marca 2019, 14:46 przez dymonek, łącznie zmieniany 2 razy.

Bardzo Zły Moderator
Awatar użytkownika
Posty: 12966
Rejestracja: 16 kwietnia 2012
Reputacja: 1768
Reputacja postu: 
0
Napiwki za post: 0 BTC
Lokalizacja: Polska / Gorzów Wlkp.

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: rav3n_pl » sobota, 2 marca 2019, 14:45

Piffko: PLC/BTC 1Rav3nkMayCijuhzcYemMiPYsvcaiwHni
Mój Skydrive; Trochę o P2pool; C#: Bitmarket SwapBot, RPC CoinControl, BIP39 Mnemonic z talii kart
Bitcoin Core 0.17.0.1

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » sobota, 2 marca 2019, 15:22

@dymonek
No tak. Ale ja chcialem miec cos nowszego niz 14 :-)
Dzieki tak czy owak. Najwyzej zrobie 14 i juz.
A ty masz w systemie jakiegos radeona? oclvanitygen go widzi pod ta 14ka?

@rav3n_pl
Tez sa bledy.
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Bardzo Zły Moderator
Awatar użytkownika
Posty: 12966
Rejestracja: 16 kwietnia 2012
Reputacja: 1768
Reputacja postu: 
0
Napiwki za post: 0 BTC
Lokalizacja: Polska / Gorzów Wlkp.

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: rav3n_pl » sobota, 2 marca 2019, 15:40

U mnie bład kompilacji załatwoło

Kod: Zaznacz cały

 sudo apt install libssl-dev
 
Piffko: PLC/BTC 1Rav3nkMayCijuhzcYemMiPYsvcaiwHni
Mój Skydrive; Trochę o P2pool; C#: Bitmarket SwapBot, RPC CoinControl, BIP39 Mnemonic z talii kart
Bitcoin Core 0.17.0.1

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » sobota, 2 marca 2019, 15:44

@rav3n_pl
a jaki numerek ubuntu?

Dodano po 4 minutach 11 sekundach:
@rav3n_pl
Lockup
Niby Twoja rada pomaga.
Ale po zainstalowaniu libssl-dev dostaje inne bledy (ponizej).
Internet na te bledy ma metode by doinstalowac libssl1.0-dev [ https://github.com/samr7/vanitygen/issues/84 ]
i tedy wracaja bledy pierwotne z openssl :-)
i tak w kolko.

--------------------------
cc -ggdb -O3 -Wall -c -o oclvanityminer.o oclvanityminer.c
In file included from oclengine.h:22:0,
from oclvanityminer.c:32:
pattern.h:54:12: error: field ‘vxc_bntarg’ has incomplete type
BIGNUM vxc_bntarg;
^~~~~~~~~~
pattern.h:55:12: error: field ‘vxc_bnbase’ has incomplete type
BIGNUM vxc_bnbase;
^~~~~~~~~~
pattern.h:56:12: error: field ‘vxc_bntmp’ has incomplete type
BIGNUM vxc_bntmp;
^~~~~~~~~
pattern.h:57:12: error: field ‘vxc_bntmp2’ has incomplete type
BIGNUM vxc_bntmp2;
^~~~~~~~~~
<builtin>: recipe for target 'oclvanityminer.o' failed
make: *** [oclvanityminer.o] Error 1
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Bardzo Zły Moderator
Awatar użytkownika
Posty: 12966
Rejestracja: 16 kwietnia 2012
Reputacja: 1768
Reputacja postu: 
0
Napiwki za post: 0 BTC
Lokalizacja: Polska / Gorzów Wlkp.

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: rav3n_pl » sobota, 2 marca 2019, 15:56

@domator na 18
Piffko: PLC/BTC 1Rav3nkMayCijuhzcYemMiPYsvcaiwHni
Mój Skydrive; Trochę o P2pool; C#: Bitmarket SwapBot, RPC CoinControl, BIP39 Mnemonic z talii kart
Bitcoin Core 0.17.0.1

Weteran
Awatar użytkownika
Posty: 3630
Rejestracja: 17 listopada 2011
Reputacja: 2046
Reputacja postu: 
0
Napiwki za post: 0 BTC
Lokalizacja: śląskie dolnośląskie małopolska

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: koparki » sobota, 2 marca 2019, 16:19

najnowszy kernel 5.0 RC8 jest dostępny, może pomoże w kwestii driverów

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » sobota, 2 marca 2019, 17:11

rav3n_pl pisze: sobota, 2 marca 2019, 15:56 @domator na 18
Hmmmm.
No to #umnieniedziala
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Początkujący
Posty: 46
Rejestracja: 5 czerwca 2012
Reputacja: 23
Reputacja postu: 
15
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: dymonek » niedziela, 3 marca 2019, 01:02

Zadziałało na 18.04

apt install build-essential libtool autotools-dev autoconf libssl-dev libdb-dev libdb++-dev libboost-all-dev libpcre3 libpcre3-dev automake
sudo apt-get install opencl-headers
sudo apt-get install libcurl4-openssl-dev
sudo ln -s /usr/lib/x86_64-linux-gnu/libOpenCL.so.1 /usr/lib/libOpenCL.so
git clone https://github.com/exploitagency/vanitygen-plus
cd vanitygen-plus
make all

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » niedziela, 3 marca 2019, 09:34

@dymonek
Dziala !!!
Linux nigdy mnie nie przestanie zadziwiac. Kluczem do sukcesu bylo przelinkowanie tej biblioteki....
Czyli tak - mam skompilowany oclvanitygen. Zdaje sie ze teraz etap drugi - drivery.
Moim zdaniem ubuntu nie widzi tej karty poprawnie
--------------------------------------------
domator@amd:~/vanitygen-plus$ ./oclvanitygen 1dupa
Difficulty: 264104224
clGetPlatformIDs(0): Unknown code -1001
clGetPlatformIDs(0): Unknown code -1001
Available OpenCL platforms:
---------------------------------------------
domator@amd:~/vanitygen-plus$ clinfo
Number of platforms 0
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Początkujący
Posty: 46
Rejestracja: 5 czerwca 2012
Reputacja: 23
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: dymonek » niedziela, 3 marca 2019, 10:37

@domator
a teraz najlepsza kaszana :D nie ma wsparcia dla tej grafy na ubuntu 18.04 xDDDDDD
https://www.amd.com/en/support/graphics ... on-hd-7950
napisane jest,że
Distributions supported:
Ubuntu 12.04.4 LTS, 14.04.2
( o ile AMD Radeon VX7950 to radeon hd 7950 - google tak wskazywało )

Coś co sie może przydać
https://linuxconfig.org/how-to-install- ... aver-linux
I to
https://askubuntu.com/questions/1040319 ... ahiti?rq=1

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » niedziela, 3 marca 2019, 10:41

@dymonek
Przerobie te linki po poludniu i zobaczymy. Ale to faktycznie by oznaczalo 14.04 jak sie nie uda :-)
Wspaniale.
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Początkujący
Posty: 46
Rejestracja: 5 czerwca 2012
Reputacja: 23
Reputacja postu: 
1
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: dymonek » niedziela, 3 marca 2019, 10:49

@domator
Nie no aż takiej tragedii to nie bedzie xD tylko wiecej zabawy może być z instalacją sterownika.
W drugim linku zdaje się jest opisana instalacja sterowników vulkan

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » niedziela, 3 marca 2019, 13:34

Jeszcze w ramach ustaelnia co tam dokladnie mam
sudo lshw -C display
*-display
description: VGA compatible controller
product: Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]

3 reinstalacje pozniej juz wiem ze nic nie uzyskalem. Nawet sciagnalem cos co sie nazywa
amdgpu-pro-18.40-697810-ubuntu-18.04 ale instalka bez bledow przechodzi tylko z parametrami --opencl=legacy --headless
Ale nawet wtedy karta nie jest widziana :-(
Kazda inna proba instalki daje pokazny pakiet brakow (following packages have unmet dependencies:......)
Driver w werrsji *.deb ze strony amd nie wchodzi pod 18 (poniewaz oczywiscie jest do 14)
Sprobuje sie przesiasc na 14 i zobaczyc czy dziala.

Dodano po 1 godzinie 3 minutach 30 sekundach:
WRRRRR
Pod 14 tez nie potrafie uruchomic driverow :-(
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Bardzo Zły Moderator
Awatar użytkownika
Posty: 12966
Rejestracja: 16 kwietnia 2012
Reputacja: 1768
Reputacja postu: 
0
Napiwki za post: 0 BTC
Lokalizacja: Polska / Gorzów Wlkp.

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: rav3n_pl » niedziela, 3 marca 2019, 14:58

A próbowałeś te "dla linux" zamiast "dla ubuntu" https://www.amd.com/en/support/graphics ... on-hd-7950 ?
Piffko: PLC/BTC 1Rav3nkMayCijuhzcYemMiPYsvcaiwHni
Mój Skydrive; Trochę o P2pool; C#: Bitmarket SwapBot, RPC CoinControl, BIP39 Mnemonic z talii kart
Bitcoin Core 0.17.0.1

Weteran
Awatar użytkownika
Posty: 3707
Rejestracja: 4 marca 2013
Reputacja: 1600
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: domator » niedziela, 3 marca 2019, 15:56

rav3n_pl pisze: niedziela, 3 marca 2019, 14:58A próbowałeś te "dla linux" zamiast "dla ubuntu"
Spoiler:
sudo dpkg -i fglrx-core_15.302-0ubuntu1_amd64_ub_14.01.deb
(Reading database ... 70261 files and directories currently installed.)
Preparing to unpack fglrx-core_15.302-0ubuntu1_amd64_ub_14.01.deb ...
Unpacking fglrx (2:15.302-0ubuntu1) over (2:15.302-0ubuntu1) ...
dpkg: dependency problems prevent configuration of fglrx:
fglrx depends on fglrx-core; however:
Package fglrx-core is not installed.

dpkg: error processing package fglrx (--install):
dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
fglrx
BitXpress - najprostszy kantor wymiany kryptowalut.
BitFilar - kryptoemerytura.
bitcoinaverage.pl - średni kurs BTC z giełd w PL

Początkujący
Posty: 46
Rejestracja: 5 czerwca 2012
Reputacja: 23
Reputacja postu: 
0
Napiwki za post: 0 BTC

oclvanitygen, openssl i ubuntu 16 lub 18

Postautor: dymonek » niedziela, 3 marca 2019, 17:43

@domator
spróbuj
sudo apt-get update
sudo apt-get install fglrx
lub
sudo apt-get update
sudo apt-get install fglrx fglrx-amdcccle fglrx-dev

( w tym błedzie co napisałeś jest napisane Package fglrx-core is not installed xD)

Wróć do „Pomoc techniczna”

Kto jest online

Użytkownicy przeglądający to forum: cyclone i 2 gości